Tango's Ultimate Hot Rod House

Members Login
Post Info TOPIC: Wiper Motor Help


Senior Member

Status: Offline
Posts: 288
Date:
Wiper Motor Help


My Cadillac Fleetwood brogham 5.7 squiters don't work. Hit buttom would click but now nothing now. My question is wiper motor and windshield pump  all one unit ? Need exploded view of pump. Winter coming fast and no sqirters. Wipers work fine. Can't seem get answer on internet.



__________________
Drive it like you stole it'


Guru

Status: Offline
Posts: 473
Date:

On those, if it clicked, that means it picked up the arm for energizing the washer pump. How ever, you may have to take the cover off, and check things. On ones I have checked before, they get a bad connection, or the linkage gets off, and do not pump. On others, the washer diaphragms will stick, and will not pump fluid. Here's a couple pictures. I hope this is the type you have. You said it clicked, so this should be the style. On the washer part. These cups will stick. They are supposed to open and close like a flapper valve.

 

Check the ground, and the 3-4 wire connector. If this is slightly corroded, it will loose connection. And check that ground to the firewall.



Attachments
__________________

I always tell the truth...even when I lie...

Head, or gut...

I give the same as I get...

-->>My truck project<<-->>My Personal Site


-->> Denny's Get Together<<-->>My Forum

cop chase



Senior Member

Status: Offline
Posts: 288
Date:

Thats the one I have Denny Thank You.



__________________
Drive it like you stole it'
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard